1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen
  2. SysProfile 2.0 - Hilf mit

    Hallo Gast,

    die Entwicklung von SysProfile 2.0 hat begonnen. Sei von Beginn an dabei und unterstütze uns durch Vorschläge und Kritik.
    Mehr Informationen findest Du im Diskussionsthread: Zum Thread
    Information ausblenden

Individuelle HDD-LED (IDE)

Dieses Thema im Forum "Festplatten, SSDs & Wechselmedien" wurde erstellt von JohnConner, 30. November 2011.

  1. JohnConner

    JohnConner Profi-Schrauber

    Registriert seit:
    15. Juni 2009
    Beiträge:
    360
    Zustimmungen:
    14
    1. SysProfile:
    107811
    2. SysProfile:
    11311

    Mahlzeit

    Ich hab ein wenig rumgebastelt. Und zwar wollte ich für jede IDE-Festplatte, die ich in meinem Rechner habe, eine seperate Aktivitäts-LED nutzen.
    Ich habe 6 IDE-Festplatten in meinem PC und somit wollte ich eben über 6 LEDs deren Aktivität anzeigen lassen.
    Dieser Status wird über das IDE-Kabel über den Pin 39 ausgegeben. Also habe ich an den IDE-Kabeln diese Ader abgegriffen, die Verbindung zum Mainboard getrennt und seperat zu jeweils einer LED geleitet - der zweite Anschluss von den LEDs erfolgt über einen Widerstand an +5V.
    Da die Master/Slave-Erkennung ebenfalls über den Pin39 erfolgt, so habe ich die Festplatten allesamt auf CableSelect gejumpert, was auch wunderbar funktioniert. Sie werden je als Master und Slave korrekt erkannt. (Erkennung läuft über Pin28 und dem entsprechenden Anschluss an den Enden der Kabel, das nur nebenbei)

    Kurze Erklärung, warum ich die Ader vom Pin39 vom Board getrennt habe: Das Signal wird durchgeschliffen, was bedeutet, wenn eine der beiden Platten arbeitet, würden immer zwei LEDs aufleuchten. Daher die Durchtrennung der einzelnen Kabelader um eben jede Platte einzeln zu einer LED abgreifen zu können.

    Nun zu meinem Problem. Die LEDs leuchten permanent, sobald der Rechner eingeschaltet ist.
    Normal sollten sie blinken, wenn sie aktiv sind und nicht leuchten, wenn sie inaktiv sind, was sie aber nicht tun. Sie leuchten eben dauerhaft, egal ob sie aktiv sind oder nicht.

    Weiss jemand wieso das so ist? Das war schlicht nicht das was ich mir erhofft hatte.
    Würde ich normale IDE-Kabel verwenden ohne eine durchtrennte Pin39-Ader, so hätte ich lediglich eine LED pro IDE-Kabel, aber nicht pro IDE-Laufwerk. Heisst, dass ich eine LED für zwei Platten hätte - was nicht Ziel meiner Bastelei ist.

    Weiss jemand Rat?

    JC
     
    #1 JohnConner, 30. November 2011
    Zuletzt bearbeitet: 30. November 2011
  2. davidof2001

    davidof2001 Computer-Guru

    Registriert seit:
    23. April 2009
    Beiträge:
    194
    Zustimmungen:
    8
    1. SysProfile:
    159616
    2. SysProfile:
    99413

    Warum hast du den zweiten Pin der LEDs an +5V angeschlossen?
    Reicht die Spannung vom Aktivitätspin nicht aus? Und dann auf Masse.
     
    #2 davidof2001, 30. November 2011
  3. JohnConner

    JohnConner Profi-Schrauber
    Themenstarter

    Registriert seit:
    15. Juni 2009
    Beiträge:
    360
    Zustimmungen:
    14
    1. SysProfile:
    107811
    2. SysProfile:
    11311
    Weil Pin39 Masse ist.
     
  4. davidof2001

    davidof2001 Computer-Guru

    Registriert seit:
    23. April 2009
    Beiträge:
    194
    Zustimmungen:
    8
    1. SysProfile:
    159616
    2. SysProfile:
    99413
    Na dann kann doch da ws nicht stimmen. Wenn über Pin 39 ein Status ausgegeben wird, dann kann er nicht Masse sein. Im Prinzip hast du die Pins der LED jetzt einmal auf Masse und einmal auf +5V? Dann ist jedenfalls klar warum sie dauerhaft leuchten.

    EDIT
    Hab mir gerade noch mal die Pinbelegung vom IDE Kabel angeschaut. Pin 39 ist NICHT Masse sondern wie du eingangs bereits erwähntest das Statussignal. Also müsstest du die LED an Pin 39 und Masse anschließen.
     
    #4 davidof2001, 1. Dezember 2011
    Zuletzt bearbeitet: 1. Dezember 2011
  5. JohnConner

    JohnConner Profi-Schrauber
    Themenstarter

    Registriert seit:
    15. Juni 2009
    Beiträge:
    360
    Zustimmungen:
    14
    1. SysProfile:
    107811
    2. SysProfile:
    11311
    Dann solltest du nochmal richtig lesen. Pin39 ist Masse.
    Bei meiner externen Festplatte habe ich bereits eine Status-LED eingebaut und dort funktioniert es wunderbar. Pin39 an die Kathode der LED und die Anode mit Widerstand an +5V.
     
  6. Django2

    Django2 Computer-Experte

    Registriert seit:
    18. Januar 2010
    Beiträge:
    1.178
    Zustimmungen:
    111
    1. SysProfile:
    123711
    Nicht ganz richtig, wäre Pin 39 Masse hättest du bei deiner Konstruktion die LED konstant am leuchten (ist zwar der Fall bei dir, sollte aber nicht so sein). Pin 39 ist der "activity" Pin, der wird nur nach Masse geschaltet bei Aktivität, was dann deine LED zum leuchten bringt.
    Ich glaub der Trick geht aber nur pro Controller (also für Master und Slave zusammen) und nicht pro Laufwerk.
     
    #6 Django2, 1. Dezember 2011
    Zuletzt bearbeitet: 1. Dezember 2011
  7. JohnConner

    JohnConner Profi-Schrauber
    Themenstarter

    Registriert seit:
    15. Juni 2009
    Beiträge:
    360
    Zustimmungen:
    14
    1. SysProfile:
    107811
    2. SysProfile:
    11311
    Hab mich falsch ausgedrückt, sorry. Pin39 ist nicht permanent Masse, aber es wird Masse geschaltet.

    Und ja, pro Controller funktioniert es, das hab ich schon getestet. Nur hatte ich die Hoffnung, dass es auch pro Laufwerk machbar wäre. :/
     
  8. BOfH

    BOfH Grünschnabel

    Registriert seit:
    14. Januar 2014
    Beiträge:
    1
    Zustimmungen:
    1
    Nun wollte ich auch etwas basteln und bin hier über euer Problem gestolpert.
    Also gebe ich auch noch meinen Senf dazu, auch wenn's schon etwas spät dafür ist.

    Ich habe festgestellt, daß eine IDE-HDD kein Signal auf Pin39 ausgibt, der Pin ist bei den Festplatten meistens gar nicht mehr belegt, es sei denn, die HDD besitzt noch irgendwo eine LED oder zumindest die Lötanschlüsse auf der Steuerplatine, oder die Steuerplatine der HDD benutzt dieses Signal irgendwie zur anderweitigen Auswertung.
    Das Signal für die LED kommt von der Controllerkarte, bzw Controller auf dem Motherboardund und liefert bei Aktivität des Controllers eine Spannung von ca. 3Volt.
    Ein Vorwiderstand sorgt für die Strombegrenzung der LED.
    Pin40 ist auf Masse gelegt und kann als Minus-Anschluß für die LED genommen werden.

    Ohne weiteres ist es also nicht möglich, pro HDD eine LED zu schalten, die Auswertung geht nur pro IDE-Anschluß.

    Mit einem Wannenstecker, Wannenbuchse und 40-poligem Flachbandkabel kann man sich einen LED-Abgriff basteln
    Dieses Kabel sollte möglichst kurz bleiben, nur Pin39 und Pin40 können beliebig lang ausgelegt, und an eine LED angelötet werden.
    Wem der Datendurchsatz dann doch nicht so wichtig ist, weil er noch einen alten PC hat, der kann sich die IDE-Kabel auch selbst bauen. (das Material gibt's bei "C"
    Am 2. IDE-Stecker kann man dann auch gleich die Schneidklemme auf Pin28 entfernen, dann hat man ein Kabel mit Master/Slave-Kennung und erspart sich das Jumpern.

    Eine andere Lösung ist ein Wannenstecker und eine doppelseitige Stiftleiste, die zu einem LED-Abgriff zusammengelötet werden.
    Man muß nur Pin39 und Pin40 abgreifen und auf eine 2polige Stiftleiste belegen.
    So lassen sich dann auch die Dupont-Stecker verwenden, die an den LED-Kabeln und dem Frontpanel zum Motherboard hängen.
    Diese Kabel sichere ich mir übrigens immer wieder aus alten PC-Gehäusen auf dem Sperrmüll, (nach Möglichkeit mit LEDs und Tastern, Lautsprecher) oder ich frage bei diversen Verwertungbetrieben nach.
    "C" hatte mal solche Kabel im Sortiment, HATTE....
    Bei einem Online-Auktionshaus findet man diese Kabel auch noch...

    Eine andere Lösung nach der Quick n' Dirty-Methode (Schnell und schmutzig) wäre der direkte Abgriff der Signale am Controller oder Motherboard, (An der Methode erkennt man den Bastler, nicht den Profi)
     
    1 Person gefällt das.
  9. Schweini

    Schweini Das Schweinchen

    Registriert seit:
    26. Dezember 2006
    Beiträge:
    4.320
    Zustimmungen:
    226
    Name:
    Daniel
    1. SysProfile:
    5879
    2. SysProfile:
    5880

    Gibt doch so Tools, die im Tray die FP Aktivität anzeigen. Stimme da zu, das macht der Controller pro Kanal. ;)
     
Die Seite wird geladen...

Individuelle HDD-LED (IDE) - Weitere Themen

Forum Datum

Mainboard HDD LED +/- Kabel

Mainboard HDD LED +/- Kabel: Mainboard HDD LED +/- Kabel
Computerfragen 3. Februar 2014

IDE oder SATA 1TB HDD

IDE oder SATA 1TB HDD: IDE oder SATA 1TB HDD ich möchte eine größere HDD für meine Daten (intern) - mind. 1 TB. Jetzt wurde mir gesagt ich brauche für meinen Rechner eine IDE HDD aber 1TB gäbe es fast...
Computerfragen 22. Mai 2010

>80GB IDE HDD? Welche?

>80GB IDE HDD? Welche?: Hoi,:o Der alte Office-PC von meinem Dad bracuht mal ne neue HDD^^, die alte ist schon recht hin und das ganze Sys läuft instabil^^ Ich würde WD bevorzugen, obwohl da heißts ja dass die sehr...
Festplatten, SSDs & Wechselmedien 10. August 2009

IDE HDD kaputt was kann ich machen?

IDE HDD kaputt was kann ich machen?: Hi wie gesagt meine 4 Jahre alte WD ist kaputt hier ein screen von HD tune [img] Was kann ich machen ??
Festplatten, SSDs & Wechselmedien 19. März 2009

Spannung HDD/Power LEDs

Spannung HDD/Power LEDs: Hi, der Titel sagt eigentlich schon alles. Welche Spannung kommt aus den Pins für die HDD/Power LEDs? EDIT: Wollte das eigentlich in den Mainboard Bereich machen :/ MfG
Grafikkarten 26. Januar 2009

Power- HDD- LED raus und 2farbige LED rein

Power- HDD- LED raus und 2farbige LED rein: high leutz, ich hab eben bei mir im keller noch eine alte front von einem uralttower gefunden, dieser hatte noch eine turbotaste mit 2farbiger led, ich habe mir jetzt in den kopf gesetzt diese...
Gehäuse & Modding 13. September 2008

HDD LED hört nicht auf zu leuchten

HDD LED hört nicht auf zu leuchten: Huhu, ich sollte einen neuen PC zusammenbauen. Es ging auch alles soweit. Erst hatte ich kleine Schwierigkeiten bei Windows auf RAID1 installieren, aber dann gings doch. Also folgendes...
Grafikkarten 17. Mai 2008

HDD Geschwindigkeit i.O. oder auch nur IDE erkannt ?

HDD Geschwindigkeit i.O. oder auch nur IDE erkannt ?: HI Leute, habe, wie ihr in meinem Profile sehen könnt, eine 250 GB Samsung Serial ATA Festplatte ! Jetzt wollte ich fragen ob diese Daten für die Platte ok sind oder sie doch nur als IDE im BIOS...
Festplatten, SSDs & Wechselmedien 15. Mai 2008

Diese Seite empfehlen