Apache2 vHost eintragen

Diskutiere und helfe bei Apache2 vHost eintragen im Bereich Webmaster Support, Scripts, etc im SysProfile Forum bei einer Lösung; Huhu! Hab gerad ein ziemliches Problem. Hab mir gerad wieder Ubuntu aufgespielt und krieg die dämliche vHost-Einstellung nicht gebacken... jegliche... Dieses Thema im Forum "Webmaster Support, Scripts, etc" wurde erstellt von Spacerat, 28. Mai 2011.

  1. Spacerat
    Spacerat ٩(̾●̮̮̃̾•̃̾)۶ /dev/null
    Registriert seit:
    25. Dezember 2006
    Beiträge:
    8.628
    Zustimmungen:
    206
    Name:
    Christian
    1. SysProfile:
    11226
    Steam-ID:
    Spacerat2911

    Huhu!

    Hab gerad ein ziemliches Problem. Hab mir gerad wieder Ubuntu aufgespielt und krieg die dämliche vHost-Einstellung nicht gebacken... jegliche Dinge aus dem Netz konnten mir NICHT helfen.... ihr seid meine letzte Hoffnung im Moment ;)

    Bis Dato sieht meine Einstellung SO aus (Projektname aus versch. Gründen mal "chiffriert" ;) ) :

    Den Verschachtelungen und Angaben nach möchte ich aus dem immer gemounteten Verzeichnis /media/Windows/xampplite/htdocs/Projekte/Projektname/www/ meine Dateien auslesen.
    Unter Windows liegen (lagen) diese Dateien unter C:\xampplite\htdocs\Projekte\Projektname\www\ (www muss angesprochen werden, da hier die indexfiles liegen ;) )

    Kann mir da jemand helfen? Der Hosts-Eintrag stimmt schon, der ist schon drin und wird auch verwendet, jedoch krieg ich immer einen Forbidden-Fehler...

    Das Verzeichnis MUSS das Selbe sein, wie ich unter Windows habe (d.h., ich will bei beiden Systemen die gleichen Ressourcen ansprechen)!

    Grüße
    Chris


    Edit: Apache wirft als Fehlermeldung, dass er im Verzeichnis /media/Windows/ nicht auf .htaccess zugreifen kann, jedoch ist das Verzeichnis nirgendwo angegeben....
     
    #1 Spacerat, 28. Mai 2011
  2. User Advert

  3. CzkOtay
    CzkOtay Hardware-Wissenschaftler
    Registriert seit:
    28. Juli 2010
    Beiträge:
    447
    Zustimmungen:
    11
    1. SysProfile:
    112138

    Hast du auch dem Apache-User die Berechtigung(777) für den "/media/Windows/"-Pfad zugewiesen ?

    BTW: Verwendest du Plesk oder Confixx ?
     
    #2 CzkOtay, 29. Mai 2011
    Zuletzt bearbeitet: 29. Mai 2011
  4. Spacerat
    Spacerat ٩(̾●̮̮̃̾•̃̾)۶ /dev/null
    Themenstarter
    Registriert seit:
    25. Dezember 2006
    Beiträge:
    8.628
    Zustimmungen:
    206
    Name:
    Christian
    1. SysProfile:
    11226
    Steam-ID:
    Spacerat2911
    Hab alles Mögliche versucht, zuzuweisen. Sowohl per chmod, als auch per chown, alles auf www-data... nix...
    selbst symlink auf /var/www/ hat mir den gleichen 403er-Fehler gebracht. :(

    Plesk und Confixx verwende ich, da ich das System im Privatgebrauch verwende, nicht :)
     
    #3 Spacerat, 29. Mai 2011
  5. CzkOtay
    CzkOtay Hardware-Wissenschaftler
    Registriert seit:
    28. Juli 2010
    Beiträge:
    447
    Zustimmungen:
    11
    1. SysProfile:
    112138
    Das ist aber schon ein öffentlicher Root, oder doch nur ein LAN-Host ?
     
  6. Spacerat
    Spacerat ٩(̾●̮̮̃̾•̃̾)۶ /dev/null
    Themenstarter
    Registriert seit:
    25. Dezember 2006
    Beiträge:
    8.628
    Zustimmungen:
    206
    Name:
    Christian
    1. SysProfile:
    11226
    Steam-ID:
    Spacerat2911
    Es ist mein produktiver Rechner, an dem ich am Tage auch selbst sitze und z.B. surfe!
     
    #5 Spacerat, 30. Mai 2011
  7. CzkOtay
    CzkOtay Hardware-Wissenschaftler
    Registriert seit:
    28. Juli 2010
    Beiträge:
    447
    Zustimmungen:
    11
    1. SysProfile:
    112138
    Verwendest du "nur" Linux, oder hast du mehrere Partitionen - oder doch eine VM ?
     
  8. Spacerat
    Spacerat ٩(̾●̮̮̃̾•̃̾)۶ /dev/null
    Themenstarter
    Registriert seit:
    25. Dezember 2006
    Beiträge:
    8.628
    Zustimmungen:
    206
    Name:
    Christian
    1. SysProfile:
    11226
    Steam-ID:
    Spacerat2911
    Wenn ich selbst dransitze und surfe, wird es keine VM sein, oder?

    Ich verwende das Linux nebst Windows als normales Betriebssystem. Windows soll nur noch für bestimmte Zwecke, z.B. eben Games, dienen.

    Ich verwende mehrere Partitionen und HDDs.

    Ich möchte von Linux nur auf die Win-Partition zugreifen und die Webdaten des Apache2 verwenden können....


    edit: Dank Steffen hat sich das Problem nun gelöst. Es war ein Mount-Problem......
     
    #7 Spacerat, 3. Juni 2011
  9. Steffen
    Steffen Apfelmännchen
    Registriert seit:
    23. Dezember 2006
    Beiträge:
    2.057
    Zustimmungen:
    124
    Name:
    Steffen
    1. SysProfile:
    1171
    2. SysProfile:
    1170
    Steam-ID:
    deus-vult

    Problem mit Spaci gelöst.
    Des Rätsels Lösung war übrigens die passende umask beim einmounten ;)
    Code:
    UUID=xxxxxx /media/Windoof ntfs rw,auto,users,nls=utf8,umask=003,gid=46 0 0
    
     
    1 Person gefällt das.
Thema:

Apache2 vHost eintragen

  1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden